PDA

View Full Version : Networking (Win98 and WinME)



Citizen Bleys
10-19-2001, 03:59 PM
Okay, I've got WinME on my laptop, and Win98 on my desktop, and I can't seem to get the god-rotting buggers networked. I've tried all the god-rotting help files, and the god-rotting Windows Help in both Win98 and god-rotting ME, to no avail. Both god-rotting machines show only their own shared folders in Network Neighborhood, as though there were no god-rotting connection at all. I'm using a D-Link PCI NIC card in my desktop, and a built-in NIC card in my laptop. My network cable is straight, not crossover, because my PCI NIC card requires straight cable.

Can somebody point out a god-rotting step-by-step networking tutorial?

Endless
10-19-2001, 04:16 PM
How do you want them to react? I mean, I suppose I can figure how to help you if you tell me want you expect to have as a "network"

Citizen Bleys
10-19-2001, 09:03 PM
K, <i>sans</i> "god rotting":

All I want is to be able to transfer files from one machine to the other, so that I can work on Shouben Densetsu on my laptop while I'm on break at work or school, and copy my modified files back to the desktop machine when I get home.

So far, I've been doing file transfers from the desktop to the laptop by burning CD's, but there's no burner in the laptop (and I'd cut a pile of throwaway CD's!), so networking them is a much more elegant solution.

Endless
10-19-2001, 09:14 PM
Open "Network Properties" (right click on network neighbourhood).

Now it's complex (*translates the technical terms on the fly*)

Tab "Configuration":
Click "Add"
In client, install "Micorsoft Win network client" and "Individual sessions..."
In protocol, get TCP/IP, NetBEUI and IPX/SPX (in Microsoft)
In services, get "File and printer sharing for Microsoft networks".

Then in "main session..." stuff, choose "Windows opening session".

The second tab, "Identification", allows to name your comps and workgroup.

Do the same on both comps. Reboot.

Citizen Bleys
10-19-2001, 09:30 PM
Already done. It must be the cable. The NIC card's manual must be lying about requiring straight network cable. I'll pick up some crossover cable instead.

Endless
10-19-2001, 09:44 PM
Make sure to check in "Printer and file sharing" "allow other users to access my files"

crono_logical
10-19-2001, 10:23 PM
1) Make sure they're on the same Workgroup :D

2) If you're connecting two Windows machines directly without a hub, you <B><U>must</U></B> use a crossover cable!!! :p

Citizen Bleys
10-22-2001, 08:47 PM
It was the cable.

Get this, though: I got it set up so that both Navi and Toshiharu would appear in Network Neighborhood and "My Network Places" (on the laptop), and mapped all 3 of my 'doze drives on Navi to Toshiharu and vice versa. I decided to disconnect them and clear the "reconnect at login" option because it was looking for the buggers even when I didn't have the network cable plugged in, and then Navi disappeared from Toshiharu's "My Network Places", but both machines appeared in Network Neighborhood" on Navi.

I could still manually access files on my desktop from my laptop by using \\navi\\balthasar, \\navi\gaspar, and \\navi\melchior, and I could still map Navi's drives to Toshiharu, but Navi wouldn't show up in "My Network Places."

Then, for no apparent reason, the problem went away.

Relena Peacecraft
10-23-2001, 06:07 AM
Yes, I've noticed that windows file sharing tends to be shaky at best. When first getting it hooked up right, it refuses to work, or has odd problems like you described. Then suddenly, it fixes itself and you never have problems again, at least until you unplug the cable for whatever reason. Then sometimes, the problems come up again. It's very odd.

Usually, to fix those problems I just shut down all the involved computers and turn them on again at the same time. Usually it works, sometimes it doesn't. *shrug*

Citizen Bleys
10-23-2001, 07:09 PM
That would work with SOME networks, but my desktop takes a LOT longer to load up and shut down than my laptop does. It takes a full 60 seconds to shut down! Plus, I can boot into <i>Linux</i> on my laptop faster than I can boot into Win98 on my desktop.

Relena Peacecraft
10-24-2001, 05:48 AM
It's not so much that they load windows/linux up at the same time. I just like the network cards to start doing what they do before the drivers take over. On a side note, I don't think I've ever had a problem accessing Windows network shares with Linux, so I blame Windows.

Citizen Bleys
10-24-2001, 06:49 PM
I figured it out. The notebook has to be running before the desktop. Natually enough, the desktop is the one that takes sixteen thousand years to load :(

crono_logical
10-24-2001, 08:01 PM
Wow, you lived that long to find out? :p